re = /(?is)(<a[^>]+href\s*=\s*(['"])([^'"]+)\2[^>]*>).*?<\/a>/m
str = '<a href="http://...">some text</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end