$re = '/^(?!.*?(?:career|special)s?).*/m';
$str = 'foo bar
abc xyz specials
abc xyz career';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);