re = /^(?!.*?(?:career|special)s?).*/m
str = 'foo bar
abc xyz specials
abc xyz career'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end