using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=(?:[a-zA-Z]\d+[a-zA-Z]*)|(?:\d+[a-zA-Z]\d*))[a-zA-Z0-9]*";
string input = @"1921 abc abc abc 1k
4320 abcs abc Apt 201b
1250 abcd Ave Apt 3c
61a abcd Ave
1b abcd Ave
39r abcd Rd
16w750 abcd Ave
a123def";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}