# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?=(?:[a-zA-Z]\d+[a-zA-Z]*)|(?:\d+[a-zA-Z]\d*))[a-zA-Z0-9]*"
test_str = ("1921 abc abc abc 1k\n\n"
"4320 abcs abc Apt 201b\n\n"
"1250 abcd Ave Apt 3c\n\n"
"61a abcd Ave\n\n"
"1b abcd Ave\n\n"
"39r abcd Rd\n\n"
"16w750 abcd Ave\n\n"
"a123def")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.