package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s?:\s?"([ \S]*?)"`)
var str = `filename:"\temp location\files\here" fileType:html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}