$re = '/(\w+)\s?:\s?"([ \S]*?)"/m';
$str = 'filename:"\\temp location\\files\\here" fileType:html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);