import re
regex = re.compile(r"^(?=[0-9.]{1,6}$)[0-9]+(?:\.[0-9]{1,3})?$", flags=re.MULTILINE)
test_str = ("123\n"
"12.345\n"
"123.789\n"
"1234.456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")