re = /^(?=[0-9.]{1,6}$)[0-9]+(?:\.[0-9]{1,3})?$/m
str = '123
12.345
123.789
1234.456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end