const regex = /([0-9]|0[0-9]|1[0-9]|2[0-3]):[0-5][0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]|0[0-9]|1[0-9]|2[0-3]):[0-5][0-9]', 'gm')
const str = `00:12
01:23
09:16
34:65
00:00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}