// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]|0[0-9]|1[0-9]|2[0-3]):[0-5][0-9]").unwrap();
let string = "00:12
01:23
09:16
34:65
00:00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}