#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+]?(\d{3,4})[\s.-]?(\d{2,9})?([\s.-])?(\d{2,3})[\s.-]?(\d{2,3})$"
Local $sString = "+777 777 777 777" & @CRLF & _
"+777.777.777.777" & @CRLF & _
"+777 777777777" & @CRLF & _
"+777-777-777-777" & @CRLF & _
"+777777777777" & @CRLF & _
"7777 777 777" & @CRLF & _
"7777 777777" & @CRLF & _
"7777.777.777" & @CRLF & _
"7777-777-777" & @CRLF & _
"777-777-777" & @CRLF & _
"777.777.777" & @CRLF & _
"7777777777" & @CRLF & _
"7777 77 77 77" & @CRLF & _
"7777.77.77.77" & @CRLF & _
"7777-77-77-77"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")