import re
regex = re.compile(r"^[+]?(\d{3,4})[\s.-]?(\d{2,9})?([\s.-])?(\d{2,3})[\s.-]?(\d{2,3})$", flags=re.MULTILINE)
test_str = ("+777 777 777 777\n"
"+777.777.777.777\n"
"+777 777777777\n"
"+777-777-777-777\n"
"+777777777777\n"
"7777 777 777\n"
"7777 777777\n"
"7777.777.777\n"
"7777-777-777\n"
"777-777-777\n"
"777.777.777\n"
"7777777777\n"
"7777 77 77 77\n"
"7777.77.77.77\n"
"7777-77-77-77")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")