use strict;
my $str = 'Какой-то текст. Дальше идет совсем другой текст.';
my $regex = qr/(\.) /mp;
my $subst = '.\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";