import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,9}(eur.*)? honoraires? exclus";
final String string = "----------------------------------------------------------------------------------\n"
+ "[REGEX_1 = hors honoraires?:? (:\\s)?\\d{1,9}]\n"
+ "----------------------------------------------------------------------------------\n"
+ "prix hors honoraires 900 000 €. no\n"
+ "prix hors honoraire 900 000 €. no\n"
+ "prix hors honoraire: 900 000 €. no\n"
+ "prix hors honoraires 168 000 € ttc.\n"
+ "prix hors honoraires 600 000 € ht. \n"
+ "prix hors honoraires 125 000 €. no\n"
+ "prix hors honoraires 2 500 000 € pa\n"
+ "prix hors honoraires 100 000 €. no\n"
+ "prix hors honoraires 250 000 € h\n"
+ "prix hors honoraires: 250 000 € h\n"
+ "prix de vente hors honoraires : 620 000 €\n\n"
+ "----------------------------------------------------------------------------------\n"
+ "[REGEX_2 = \\d{1,9} ([a-zA-Z_\\/€² ]{1,12}) (\\w{1,5}\\s)?hors honoraires?]\n"
+ "----------------------------------------------------------------------------------\n"
+ "1 050 000 € hors honoraires\n"
+ "450 000 euros hors honoraires\n"
+ "287600 eur hors honoraires\n"
+ "450 ht/hc/m²/an hors honoraires\n"
+ "450 € /m2 ht/hc/an hors honoraires\n"
+ "450 m²/an/ht/hc et hors honoraires\n"
+ "450 m²/an/ ht hc et hors honoraires\n\n"
+ "----------------------------------------------------------------------------------\n"
+ "[REGEX_3 = \\d{1,9}(eur.*)? hors honoraires?]\n"
+ "----------------------------------------------------------------------------------\n"
+ "65 000 hors honoraires \n"
+ "400000eur hors honoraires \n\n"
+ "----------------------------------------------------------------------------------\n"
+ "[REGEX_4 = honoraires? exclus:? (:\\s)?\\d{1,9}]\n"
+ "----------------------------------------------------------------------------------\n"
+ "prix honoraires exclus : 80 000 eur\n"
+ "prix honoraires exclus : 550 000 eur\n"
+ "prix honoraires exclus: 550 000 eur\n\n"
+ "----------------------------------------------------------------------------------\n"
+ "[REGEX_5 = \\d{1,9} ([a-zA-Z_\\/€² ]{1,12}) (\\w{1,5}\\s)?honoraires? exclus]\n"
+ "----------------------------------------------------------------------------------\n"
+ "65 000 eur honoraires exclus\n"
+ "400000 ht/hc/m²/an honoraires exclus\n"
+ "400000 ht hc m²/an honoraires exclus\n"
+ "450 m²/an/ht/hc et honoraires exclus\n"
+ "450 m²/an/ ht hc et honoraires exclus\n"
+ "450 m²/an/ ht hc et honoraires exclus\n\n"
+ "----------------------------------------------------------------------------------\n"
+ "[REGEX_6 = \\d{1,9}(eur.*)? honoraires? exclus]\n"
+ "----------------------------------------------------------------------------------\n"
+ "65 000 honoraires exclus\n"
+ "400000eur ht/hc/m²/an honoraires exclus\n"
+ "400000eur ht/hc/m²/an et honoraires exclus\n"
+ "400000eur ht hc m²/an honoraires exclus\n"
+ "400000eur ht hc m²/an et honoraires exclus\n"
+ "400000eur honoraires exclus\n\n"
+ "[GOOD ONE]\n"
+ "bail 30/06/22 honoraires exclus\n"
+ "prix honoraires exclus \n"
+ "honoraires exclus \n"
+ "prix hors honoraires \n"
+ "bail 30/06/22 hors honoraires\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}