// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,9}(eur.*)? honoraires? exclus").unwrap();
let string = "----------------------------------------------------------------------------------
[REGEX_1 = hors honoraires?:? (:\\s)?\\d{1,9}]
----------------------------------------------------------------------------------
prix hors honoraires 900 000 €. no
prix hors honoraire 900 000 €. no
prix hors honoraire: 900 000 €. no
prix hors honoraires 168 000 € ttc.
prix hors honoraires 600 000 € ht.
prix hors honoraires 125 000 €. no
prix hors honoraires 2 500 000 € pa
prix hors honoraires 100 000 €. no
prix hors honoraires 250 000 € h
prix hors honoraires: 250 000 € h
prix de vente hors honoraires : 620 000 €
----------------------------------------------------------------------------------
[REGEX_2 = \\d{1,9} ([a-zA-Z_\\/€² ]{1,12}) (\\w{1,5}\\s)?hors honoraires?]
----------------------------------------------------------------------------------
1 050 000 € hors honoraires
450 000 euros hors honoraires
287600 eur hors honoraires
450 ht/hc/m²/an hors honoraires
450 € /m2 ht/hc/an hors honoraires
450 m²/an/ht/hc et hors honoraires
450 m²/an/ ht hc et hors honoraires
----------------------------------------------------------------------------------
[REGEX_3 = \\d{1,9}(eur.*)? hors honoraires?]
----------------------------------------------------------------------------------
65 000 hors honoraires
400000eur hors honoraires
----------------------------------------------------------------------------------
[REGEX_4 = honoraires? exclus:? (:\\s)?\\d{1,9}]
----------------------------------------------------------------------------------
prix honoraires exclus : 80 000 eur
prix honoraires exclus : 550 000 eur
prix honoraires exclus: 550 000 eur
----------------------------------------------------------------------------------
[REGEX_5 = \\d{1,9} ([a-zA-Z_\\/€² ]{1,12}) (\\w{1,5}\\s)?honoraires? exclus]
----------------------------------------------------------------------------------
65 000 eur honoraires exclus
400000 ht/hc/m²/an honoraires exclus
400000 ht hc m²/an honoraires exclus
450 m²/an/ht/hc et honoraires exclus
450 m²/an/ ht hc et honoraires exclus
450 m²/an/ ht hc et honoraires exclus
----------------------------------------------------------------------------------
[REGEX_6 = \\d{1,9}(eur.*)? honoraires? exclus]
----------------------------------------------------------------------------------
65 000 honoraires exclus
400000eur ht/hc/m²/an honoraires exclus
400000eur ht/hc/m²/an et honoraires exclus
400000eur ht hc m²/an honoraires exclus
400000eur ht hc m²/an et honoraires exclus
400000eur honoraires exclus
[GOOD ONE]
bail 30/06/22 honoraires exclus
prix honoraires exclus
honoraires exclus
prix hors honoraires
bail 30/06/22 hors honoraires
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}