re = /name="__RequestVerificationToken" type="hidden"\s*value="(.+?)" /
str = '<input name="__RequestVerificationToken" type="hidden"
value="BeRYiSIRjZoQHq4VW8qbkgXlnnzdUINpFNoYF_ugx-FRk0tkImbQPhwyYjyz_0Q-w6F2A0gDOfMZrdklD6rVn6-QnYggfImb55f90V7nrD_kbSkT3-y3gPqoTFg0ynTBLyX5Lw2" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end