import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\/?\\w*color(?:=\\w+)?]";
final String string = "[valign px=-2][center][bgcolor=GREEN]TESTING[/bgcolor][/center][/valign]\n\n"
+ "color=GREEN] AND color] ---> Target ---> [bgcolor=GREEN] AND [/bgcolor]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}