const regex = /\[\/?\w*color(?:=\w+)?]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\\/?\\w*color(?:=\\w+)?]', 'gm')
const str = `[valign px=-2][center][bgcolor=GREEN]TESTING[/bgcolor][/center][/valign]
color=GREEN] AND color] ---> Target ---> [bgcolor=GREEN] AND [/bgcolor]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}