#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[a-zA-Z][a-zA-Z]+[a-zA-Z]$";"
Local $sString = "reg@asld@fja.com" & @CRLF & _
"reg.exp.email@gmial@gmail.com" & @CRLF & _
"reg.exp.email@gm@il.com" & @CRLF & _
"reg.exp.themail@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")