re = /"[a-zA-Z][a-zA-Z]+[a-zA-Z]$";/m
str = 'reg@asld@fja.com
reg.exp.email@gmial@gmail.com
reg.exp.email@gm@il.com
reg.exp.themail@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end