#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^14:00(?=[^]]*error)[^]]*XXCODE[^]]*\]"
Local $sString = "14:00:01 | some text XXCODE <some text> " & @CRLF & _
"some text " & @CRLF & _
"] " & @CRLF & _
"14:00:02 | some text <some text> XXCODE error " & @CRLF & _
"sometext" & @CRLF & _
"]" & @CRLF & _
"14:00:02 | some text <some text> error XXCODE" & @CRLF & _
"sometext" & @CRLF & _
"]" & @CRLF & _
"14:00:03 | some text XXCODE <some text> " & @CRLF & _
"some text" & @CRLF & _
"and more text 412432 " & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")