use strict;
my $str = '14:00:01 | some text XXCODE <some text>
some text
]
14:00:02 | some text <some text> XXCODE error
sometext
]
14:00:02 | some text <some text> error XXCODE
sometext
]
14:00:03 | some text XXCODE <some text>
some text
and more text 412432
]';
my $regex = qr/^14:00(?=[^]]*error)[^]]*XXCODE[^]]*\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}