package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<start>\d{1,2}) ?[-/] ?(?P<end>\d{1,2})[ /]{0,2}(?P<year>\d{2,4})`)
var str = `1-12/ 2022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}