use strict;
my $str = '1-12/ 2022';
my $regex = qr/(?P<start>\d{1,2}) ?[-/] ?(?P<end>\d{1,2})[ /]{0,2}(?P<year>\d{2,4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}