package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,]+,\s*([^,]+)`)
var str = `123 Main St, Los Angeles, CA, 90210`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}