$re = '/^[^,]+,\s*([^,]+)/m';
$str = '123 Main St, Los Angeles, CA, 90210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);