const regex = /^(?=[A-Z0-9\h]{1,8}$)[A-Z][A-Z0-9]*\h*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[A-Z0-9\\h]{1,8}$)[A-Z][A-Z0-9]*\\h*$', 'gm')
const str = `A234567
A234567 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}