$re = '/^(?=[A-Z0-9\h]{1,8}$)[A-Z][A-Z0-9]*\h*$/m';
$str = 'A234567
A234567 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);