package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(AsDate|asdate|ASDATE)\((".*"),(.+)\)\s*`)
var str = `asdate("yyyy MM",x)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}