const regex = /(AsDate|asdate|ASDATE)\((".*"),(.+)\)\s*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(AsDate|asdate|ASDATE)\\((".*"),(.+)\\)\\s*', '')
const str = `asdate("yyyy MM",x)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}