#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b[A-Z]*\d+\.\d{2}| )([A-Z0-9]{2}) "
Local $sString = "ABC WS PIT342.55USD342.55END" & @CRLF & _
"ABC WS YMQ234.03WS TOY234.03USD468.06END" & @CRLF & _
"FUR BB LAB Q10.00 199.00USD209.00END" & @CRLF & _
"YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END" & @CRLF & _
"PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END" & @CRLF & _
"YAS DL X/XXX MO X/POP DF PSC241.30ET X/SAE DL X/KOO DL CSG269.80USD511.10END" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"pattern1: " ([A-Z0-9]{2}) "" & @CRLF & _
"pattern2: "\b[A-Z ]*\d+\.\d{2}([A-Z0-9]{2}) ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")