import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b[A-Z]*\\d+\\.\\d{2}| )([A-Z0-9]{2}) ";
final String string = "ABC WS PIT342.55USD342.55END\n"
+ "ABC WS YMQ234.03WS TOY234.03USD468.06END\n"
+ "FUR BB LAB Q10.00 199.00USD209.00END\n"
+ "YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END\n"
+ "PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END\n"
+ "YAS DL X/XXX MO X/POP DF PSC241.30ET X/SAE DL X/KOO DL CSG269.80USD511.10END\n\n\n"
+ "pattern1: \" ([A-Z0-9]{2}) \"\n"
+ "pattern2: \"\\b[A-Z ]*\\d+\\.\\d{2}([A-Z0-9]{2}) \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}