$re = '/"[^"]*\.\/images\/[^"]*\.html"/m';
$str = '"./images/delete.html"
"http.google.com"
this is a text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);