re = /"[^"]*\.\/images\/[^"]*\.html"/m
str = '"./images/delete.html"
"http.google.com"
this is a text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end