$re = '/>.*?</m';
$str = ' <title>WhatsApp</title>
<meta name="viewport" content="edited text">
<meta name="google" content="edited text">
<meta name="format-detection" content="edited text">
<meta name="description" content="edited text">
<meta name="og:description" content="edited text">
<meta name="og:url" content="edited text">
<meta name="og:title" content="edited text">
<meta name="og:image" content="edited text">
<link rel="apple-touch-icon" sizes="194x194" href="/apple-touch-icon.png" type="image/png">
<link rel="stylesheet" href="/cssm_qr.1de71c5f94dde5fbf180fe974849b354.css">
<style>
html,
body,
#app {
height: 100%;
width: 100%;
overflow: hidden;
padding: 0;
margin: 0;
----------------
<div tabindex="-1" class="_2EoyP">
<div class="_3qx7_"><button class="_3e4VU"><div class="_1MdKA gt-MT"><span data-testid="back" data-icon="back" class=""><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" width="24" height="24"><path fill="currentColor" d="M12 4l1.4 1.4L7.8 11H20v2H7.8l5.6 5.6L12 20l-8-8 8-8z"></path></svg></span></div><div class="_1MdKA w-vsN"><span data-testid="search" data-icon="search" class=""><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" width="24" height="24"><path fill="currentColor" d="M15.009 13.805h-.636l-.22-.219a5.184 5.184 0 0 0 1.256-3.386 5.207 5.207 0 1 0-5.207 5.208 5.183 5.183 0 0 0 3.385-1.255l.221.22v.635l4.004 3.999 1.194-1.195-3.997-4.007zm-4.808 0a3.605 3.605 0 1 1 0-7.21 3.605 3.605 0 0 1 0 7.21z"></path></svg></span></div></button><span></span>
<div class="J3VFH">Pesquise ou crie uma conversa</div><label class="_3xpD_"><div tabindex="-1" class="_2FVVk cBxw-"><div class="_2FbwG" style="visibility: visible;"></div><div class="_3FRCZ copyable-text selectable-text" data-tab="3" dir="ltr" contenteditable="true"></div></div></label></div>
---------------
<div class="_2kHpK">
<div class="_3dtfX">
<div class="_3CneP"><span class="_357i8"><span dir="auto" title="edited text" class="_3ko75 _5h6Y_ _3Whw5">Some text</span>
<div class="_3XFan"></div>
</span>
</div>
<div class="m61XR">ontem</div>
</div>
<div class="_1582E">
<div class="_3tBW6"><span class="_2iq-U" title="edited text"><span dir="ltr" class="_3ko75 _5h6Y_ _3Whw5">Some text</span></span>
</div>
<div class="m61XR"><span></span><span></span><span></span></div>
</div>
</div>
--------------
<div class="_2kHpK">
<div class="_3dtfX">
<div class="_3CneP">
<div class="_357i8"><span dir="auto" title="edited text" class="_3ko75 _5h6Y_ _3Whw5">Some text<img crossorigin="anonymous" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" draggable="false" style="background-position: 0px -20px;" class="b3 emoji wa _3Whw5"></span>
<div class="_3XFan"></div>
</div>
</div>
<div class="m61XR">08:41</div>
</div>
<div class="_1582E">
<div class="_3tBW6"><span class="_2iq-U" title="Some text that
cross lines
more than twice.
"><div class="zFnXi"><span data-testid="status-check" data-icon="status-check" class=""><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 14 18" width="14" height="18"><path fill="currentColor" d="M12.502 5.035l-.57-.444a.434.434 0 0 0-.609.076l-6.39 8.198a.38.38 0 0 1-.577.039l-2.614-2.556a.435.435 0 0 0-.614.007l-.505.516a.435.435 0 0 0 .007.614l3.887 3.8a.38.38 0 0 0 .577-.039l7.483-9.602a.435.435 0 0 0-.075-.609z"></path></svg></span></div><span dir="ltr" class="_3ko75 _5h6Y_ _3Whw5">Some text that
cross lines
more than twice.
</span></span>
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);