# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">.*?<"
test_str = (" <title>WhatsApp</title>\n"
" <meta name=\"viewport\" content=\"edited text\">\n"
" <meta name=\"google\" content=\"edited text\">\n"
" <meta name=\"format-detection\" content=\"edited text\">\n"
" <meta name=\"description\" content=\"edited text\">\n"
" <meta name=\"og:description\" content=\"edited text\">\n"
" <meta name=\"og:url\" content=\"edited text\">\n"
" <meta name=\"og:title\" content=\"edited text\">\n"
" <meta name=\"og:image\" content=\"edited text\">\n"
" <link rel=\"apple-touch-icon\" sizes=\"194x194\" href=\"/apple-touch-icon.png\" type=\"image/png\">\n"
" <link rel=\"stylesheet\" href=\"/cssm_qr.1de71c5f94dde5fbf180fe974849b354.css\">\n"
" <style>\n"
" html,\n"
" body,\n"
" #app {\n"
" height: 100%;\n"
" width: 100%;\n"
" overflow: hidden;\n"
" padding: 0;\n"
" margin: 0;\n\n"
"----------------\n"
" <div tabindex=\"-1\" class=\"_2EoyP\">\n"
" <div class=\"_3qx7_\"><button class=\"_3e4VU\"><div class=\"_1MdKA gt-MT\"><span data-testid=\"back\" data-icon=\"back\" class=\"\"><svg xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 24 24\" width=\"24\" height=\"24\"><path fill=\"currentColor\" d=\"M12 4l1.4 1.4L7.8 11H20v2H7.8l5.6 5.6L12 20l-8-8 8-8z\"></path></svg></span></div><div class=\"_1MdKA w-vsN\"><span data-testid=\"search\" data-icon=\"search\" class=\"\"><svg xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 24 24\" width=\"24\" height=\"24\"><path fill=\"currentColor\" d=\"M15.009 13.805h-.636l-.22-.219a5.184 5.184 0 0 0 1.256-3.386 5.207 5.207 0 1 0-5.207 5.208 5.183 5.183 0 0 0 3.385-1.255l.221.22v.635l4.004 3.999 1.194-1.195-3.997-4.007zm-4.808 0a3.605 3.605 0 1 1 0-7.21 3.605 3.605 0 0 1 0 7.21z\"></path></svg></span></div></button><span></span>\n"
" <div class=\"J3VFH\">Pesquise ou crie uma conversa</div><label class=\"_3xpD_\"><div tabindex=\"-1\" class=\"_2FVVk cBxw-\"><div class=\"_2FbwG\" style=\"visibility: visible;\"></div><div class=\"_3FRCZ copyable-text selectable-text\" data-tab=\"3\" dir=\"ltr\" contenteditable=\"true\"></div></div></label></div>\n"
"---------------\n"
" <div class=\"_2kHpK\">\n"
" <div class=\"_3dtfX\">\n"
" <div class=\"_3CneP\"><span class=\"_357i8\"><span dir=\"auto\" title=\"edited text\" class=\"_3ko75 _5h6Y_ _3Whw5\">Some text</span>\n"
" <div class=\"_3XFan\"></div>\n"
" </span>\n"
" </div>\n"
" <div class=\"m61XR\">ontem</div>\n"
" </div>\n"
" <div class=\"_1582E\">\n"
" <div class=\"_3tBW6\"><span class=\"_2iq-U\" title=\"edited text\"><span dir=\"ltr\" class=\"_3ko75 _5h6Y_ _3Whw5\">Some text</span></span>\n"
" </div>\n"
" <div class=\"m61XR\"><span></span><span></span><span></span></div>\n"
" </div>\n"
" </div>\n"
"--------------\n"
" <div class=\"_2kHpK\">\n"
" <div class=\"_3dtfX\">\n"
" <div class=\"_3CneP\">\n"
" <div class=\"_357i8\"><span dir=\"auto\" title=\"edited text\" class=\"_3ko75 _5h6Y_ _3Whw5\">Some text<img crossorigin=\"anonymous\" src=\"data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7\" alt=\"\" draggable=\"false\" style=\"background-position: 0px -20px;\" class=\"b3 emoji wa _3Whw5\"></span>\n"
" <div class=\"_3XFan\"></div>\n"
" </div>\n"
" </div>\n"
" <div class=\"m61XR\">08:41</div>\n"
" </div>\n"
" <div class=\"_1582E\">\n\n"
" <div class=\"_3tBW6\"><span class=\"_2iq-U\" title=\"Some text that\n"
"cross lines\n"
"more than twice.\n"
"\"><div class=\"zFnXi\"><span data-testid=\"status-check\" data-icon=\"status-check\" class=\"\"><svg xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 14 18\" width=\"14\" height=\"18\"><path fill=\"currentColor\" d=\"M12.502 5.035l-.57-.444a.434.434 0 0 0-.609.076l-6.39 8.198a.38.38 0 0 1-.577.039l-2.614-2.556a.435.435 0 0 0-.614.007l-.505.516a.435.435 0 0 0 .007.614l3.887 3.8a.38.38 0 0 0 .577-.039l7.483-9.602a.435.435 0 0 0-.075-.609z\"></path></svg></span></div><span dir=\"ltr\" class=\"_3ko75 _5h6Y_ _3Whw5\">Some text that\n"
"cross lines\n"
"more than twice.\n"
"</span></span>\n"
" </div>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.