# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([א-ת])(\1{2})\1+/$1$2/gm;t' <<< "דחוףףףףףףףףףף"