#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{1,2})(\s*|\/|[-]|[.])([A-Za-z]+|[0-1]*[0-9]|[ก-๙]+|[ก-๙]{1,2}.[ก-๙].)(\s*|\/|[-]|[.])([0-9]{2,4})$"
Local $sString = "14 ก.พ. 62" & @CRLF & _
"" & @CRLF & _
"2018/07/18" & @CRLF & _
"" & @CRLF & _
"24 มิ.ย. 41" & @CRLF & _
"" & @CRLF & _
"7กย62" & @CRLF & _
"" & @CRLF & _
"13 กันยายน 2535" & @CRLF & _
"" & @CRLF & _
"1ธันวาคม2561" & @CRLF & _
"" & @CRLF & _
"1ธันวา2561" & @CRLF & _
"" & @CRLF & _
"13 กันยายน 2535" & @CRLF & _
"" & @CRLF & _
"5 กันยา 61" & @CRLF & _
"" & @CRLF & _
"1กันยา2501" & @CRLF & _
"" & @CRLF & _
"1 September 2018" & @CRLF & _
"" & @CRLF & _
"15October18" & @CRLF & _
"" & @CRLF & _
"1/9/2018" & @CRLF & _
"" & @CRLF & _
"10/3/2018" & @CRLF & _
"" & @CRLF & _
"12/12/2018" & @CRLF & _
"" & @CRLF & _
"4 กันยา 2018" & @CRLF & _
"" & @CRLF & _
"12-12-18" & @CRLF & _
"" & @CRLF & _
"12-9-2018" & @CRLF & _
"" & @CRLF & _
"12Sep 2018" & @CRLF & _
"" & @CRLF & _
"15มีนาคม 2018" & @CRLF & _
"" & @CRLF & _
"15.Sep.2018"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")