package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{1,2})(\s*|\/|[-]|[.])([A-Za-z]+|[0-1]*[0-9]|[ก-๙]+|[ก-๙]{1,2}.[ก-๙].)(\s*|\/|[-]|[.])([0-9]{2,4})$`)
var str = `14 ก.พ. 62
2018/07/18
24 มิ.ย. 41
7กย62
13 กันยายน 2535
1ธันวาคม2561
1ธันวา2561
13 กันยายน 2535
5 กันยา 61
1กันยา2501
1 September 2018
15October18
1/9/2018
10/3/2018
12/12/2018
4 กันยา 2018
12-12-18
12-9-2018
12Sep 2018
15มีนาคม 2018
15.Sep.2018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}