import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<FlightDesignator>([A-Z0-9]{2}[A-Z]?)([0-9]{3,4}))(?<OperationalSuffix>[A-Z])?(?<FlightIdentifierDate>\\/(\\d{2})([A-Z]{3})?(\\d{2})?)?(\\s(?<FlightLegsChangeIdentifier>(\\/?[A-Z]{3})+)(?=(\\s|$)))?(\\s1(?<JointOperationAirlineDesignators>(\\/.{2}[A-Z]?)+))?(\\s3\\/(?<AircraftOwner>([A-Z]{2}|.)))?(\\s4\\/(?<CockpitCrewEmployer>(.+?)(?=(?: \\d\\/|$))))?(\\s5\\/(?<CabinCrewEmployer>([A-Z]{2}|.)))?(?<OnwardFlight>\\s6\\/(([A-Z0-9]{2}[A-Z]?)([0-9]{3,4}))([A-Z])?(\\/(\\d{2})([A-Z]{3})?(\\d{2})?)?)?(\\s7\\/(?<MealServiceNote>(\\/?[A-Z]{0,3})+))?(\\s9\\/(?<OperatingAirlineDisclosure>(.{2}[A-Z]?)))?";
final String string = "BNE1010/1000 HKG1955/2005 7/PLD/CLD/YLD\n"
+ "RG878A/21AUG15 GIG/BOG 1/RG/AV 3/AV 4/AV 5/RG 6/AV081C/22 7/CDC/YD 9/TP";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}