package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([[:alpha:]]*[[:blank:]])(\d{2})(.*)$`)
var str = `Population 1222
Population 90over
population under78
population 99101
Population 1254
Population 78 92
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}