#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[:,]([\w \<]+)([\w.-]+@[\w.-]+\.[\w.-]+)"
Local $sString = " > Begin forwarded message:" & @CRLF & _
">=20" & @CRLF & _
"> Date: December 20, 2013 at 11:32:39 AM GMT-3" & @CRLF & _
"> Subject: My dummy subject" & @CRLF & _
"> From: Charlie Brown <aaa@aa-aaa.com>" & @CRLF & _
"> To: maria.brown@aaa.com, George Washington <george@washington.com>, =" & @CRLF & _
"thomas.jefferson@aaa.com, thomas.alva.edison@aaa.com, Juan =" & @CRLF & _
"<juan@aaa.com>, Alan <alan@aaa.com>, Alec <alec@aaa.com>, =" & @CRLF & _
"Alejandro <aaa@aaa.com>, Alex <aaa@planeas.com>, Andrea =" & @CRLF & _
"<andrea.mery@thomsen.cl>, Andrea <andrea.22@aaa.com>, Andres =" & @CRLF & _
"<andres@aaa.com>, Andres <avaldivieso@aaa.com>" & @CRLF & _
"> Hi," & @CRLF & _
"> Please reply ASAP with your RSVP" & @CRLF & _
"> Bye"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")