import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[:,]([\\w \\<]+)([\\w.-]+@[\\w.-]+\\.[\\w.-]+)";
final String string = " > Begin forwarded message:\n"
+ ">=20\n"
+ "> Date: December 20, 2013 at 11:32:39 AM GMT-3\n"
+ "> Subject: My dummy subject\n"
+ "> From: Charlie Brown <aaa@aa-aaa.com>\n"
+ "> To: maria.brown@aaa.com, George Washington <george@washington.com>, =\n"
+ "thomas.jefferson@aaa.com, thomas.alva.edison@aaa.com, Juan =\n"
+ "<juan@aaa.com>, Alan <alan@aaa.com>, Alec <alec@aaa.com>, =\n"
+ "Alejandro <aaa@aaa.com>, Alex <aaa@planeas.com>, Andrea =\n"
+ "<andrea.mery@thomsen.cl>, Andrea <andrea.22@aaa.com>, Andres =\n"
+ "<andres@aaa.com>, Andres <avaldivieso@aaa.com>\n"
+ "> Hi,\n"
+ "> Please reply ASAP with your RSVP\n"
+ "> Bye";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}