re = /(?<=(\w)'(?!\1))/
str = '\'a\'a\'a\'a\'b\'c\'c\'a\'a\'d\'e\'e\'e\'e'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result