import Foundation
let pattern = #"(?<=(\w)'(?!\1))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"'a'a'a'a'b'c'c'a'a'd'e'e'e'e"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)