import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z0-9]{4,5}-[A-Z0-9]{4,5}-[A-Z0-9]{4,5}";
final String string = "AAA4-AA4A-AAA4\n"
+ "AA44A-A44AA-AA44A\n"
+ "AAA-AAA-AAA\n"
+ "AAA-AAA-AAA\n"
+ "AAA-AAA-AAA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}