import re
regex = re.compile(r"[A-Z0-9]{4,5}-[A-Z0-9]{4,5}-[A-Z0-9]{4,5}")
test_str = ("AAA4-AA4A-AAA4\n"
"AA44A-A44AA-AA44A\n"
"AAA-AAA-AAA\n"
"AAA-AAA-AAA\n"
"AAA-AAA-AAA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")