package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+)`)
var str = `3454334|6456454|543534|534543534354354354356`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}