$re = '/([0-9]+)/';
$str = '3454334|6456454|543534|534543534354354354356';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);